УДК 004

ПРИМЕНЕНИЕ МЕТОДА МОНТЕ-КАРЛО В ЭКОНОМИКЕ

Прасолова Елизавета Александровна1, Копырина Татьяна Олеговна1
1Магнитогорский государственный технический университет им. Г.И.Носова, студент Института энергетики и автоматизированных систем

Аннотация
Данная статья посвящена обзору использования метода Монте-Карло, применяемого в имитационном моделировании. В статье будет рассматриваться определенный пример с дальнейшими расчетами.

Ключевые слова: имитационное моделирование, имитация, метод Монте-Карло


APPLICATION MONTE CARLO METHOD IN ECONOMICS

Prasolova Elizaveta Aleksandrovna1, Kopyirina Tatyana Olegovna1
1Nosov Magnitogorsk State Technical University, Student of Department Business-Informatics and Information Technologies

Abstract
This article reviews the use of Monte Carlo used in the simulation. In this article, we will consider the particular example with further calculations.

Keywords: imitation, imitation modelling, Monte Carlo method


Рубрика: 05.00.00 ТЕХНИЧЕСКИЕ НАУКИ

Библиографическая ссылка на статью:
Прасолова Е.А., Копырина Т.О. Применение метода Монте-Карло в экономике // Современные научные исследования и инновации. 2017. № 2 [Электронный ресурс]. URL: http://web.snauka.ru/issues/2017/02/76636 (дата обращения: 29.09.2017).

Имитационное моделирование (ситуационное моделирование) — методика построения моделей, которые описывают процессы так, как они протекали бы в действительности. Эти модели можно «проиграть» во времени для испытаний. При этом результаты будут определяться случайным характером процессов. По полученным таким образом данным можно получить достаточно устойчивую и точную статистику.

Имитационным моделированием пользуются в таких случаях, как:

  • Большая стоимость реальных экспериментов на объекте или невозможность данного эксперимента
  • Необходимо наглядное представление поведения системы или объекта во времени

Можно выделить две разновидности имитации:

  • Метод Монте-Карло (метод статистических испытаний);
  • Метод имитационного моделирования (статистическое моделирование).

Область применения метода Монте-Карло достаточно широка. В качестве примеров можно привести расчет систем массового обслуживания, расчет качества и надежности изделий, вычисление определенного интеграла и др.

Цель статьи – показать использование метода Монте-Карло в экономической сфере.

Рассмотрим при помощи метода Монте-Карло какую-то организацию «М», которая планирует внедрить определенный инвестиционный проект по изготовлению товара «А». При анализе были определены главные параметры и их границы определения в данном проекте.

Таблица 1 – Ключевые параметры проекта

Ключевые (измеряемые) параметры проекта
Показатели Минимум Максимум
Объем выпуска (продаж) 200 350
Цена единицы 50 75
Переменные затраты 22 40

 Таблица 2 – Постоянные параметры проекта

Постоянные параметры проекта
Показатели Наиболее вероятное значение
Постоянные затраты 600
Амортизация 90
Налог на прибыль 25%
Норма дисконта 15%
Срок проекта 7
Начальные инвестиции 3500

Далее после выявления этих параметров был проведен имитационный эксперимент при помощи MS Excel и встроенных в него функций.

С помощью формулы СЛУЧМЕЖДУ, которая позволяет получить случайное число из заданного интервала, была построена генеральная совокупность для таких параметров как переменные затраты, объем выпуска, цена, себестоимость, выручка, прибыль, денежный поток и приведенная стоимость.

 Таблица 3 – Вычисления параметров

Имитация Количество опытов:200
Переменые затраты Объем выпуска Цена Себестоимость Выручка Прибыль Денежный поток NCF Приведенная стоимость NVP
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A20*B20 =C20*B20 =ЕСЛИ((E20-D20-$B$11)>0;(E20-D20-$B$11)*(1-$B$13);(E20-D20-$B$11)) =F20+$B$12 =ПС($B$14;$B$15;-G20;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A21*B21 =C21*B21 =ЕСЛИ((E21-D21-$B$11)>0;(E21-D21-$B$11)*(1-$B$13);(E21-D21-$B$11)) =F21+$B$12 =ПС($B$14;$B$15;-G21;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A22*B22 =C22*B22 =ЕСЛИ((E22-D22-$B$11)>0;(E22-D22-$B$11)*(1-$B$13);(E22-D22-$B$11)) =F22+$B$12 =ПС($B$14;$B$15;-G22;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A23*B23 =C23*B23 =ЕСЛИ((E23-D23-$B$11)>0;(E23-D23-$B$11)*(1-$B$13);(E23-D23-$B$11)) =F23+$B$12 =ПС($B$14;$B$15;-G23;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A24*B24 =C24*B24 =ЕСЛИ((E24-D24-$B$11)>0;(E24-D24-$B$11)*(1-$B$13);(E24-D24-$B$11)) =F24+$B$12 =ПС($B$14;$B$15;-G24;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A25*B25 =C25*B25 =ЕСЛИ((E25-D25-$B$11)>0;(E25-D25-$B$11)*(1-$B$13);(E25-D25-$B$11)) =F25+$B$12 =ПС($B$14;$B$15;-G25;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A26*B26 =C26*B26 =ЕСЛИ((E26-D26-$B$11)>0;(E26-D26-$B$11)*(1-$B$13);(E26-D26-$B$11)) =F26+$B$12 =ПС($B$14;$B$15;-G26;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A27*B27 =C27*B27 =ЕСЛИ((E27-D27-$B$11)>0;(E27-D27-$B$11)*(1-$B$13);(E27-D27-$B$11)) =F27+$B$12 =ПС($B$14;$B$15;-G27;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A28*B28 =C28*B28 =ЕСЛИ((E28-D28-$B$11)>0;(E28-D28-$B$11)*(1-$B$13);(E28-D28-$B$11)) =F28+$B$12 =ПС($B$14;$B$15;-G28;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A29*B29 =C29*B29 =ЕСЛИ((E29-D29-$B$11)>0;(E29-D29-$B$11)*(1-$B$13);(E29-D29-$B$11)) =F29+$B$12 =ПС($B$14;$B$15;-G29;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A30*B30 =C30*B30 =ЕСЛИ((E30-D30-$B$11)>0;(E30-D30-$B$11)*(1-$B$13);(E30-D30-$B$11)) =F30+$B$12 =ПС($B$14;$B$15;-G30;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A31*B31 =C31*B31 =ЕСЛИ((E31-D31-$B$11)>0;(E31-D31-$B$11)*(1-$B$13);(E31-D31-$B$11)) =F31+$B$12 =ПС($B$14;$B$15;-G31;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A32*B32 =C32*B32 =ЕСЛИ((E32-D32-$B$11)>0;(E32-D32-$B$11)*(1-$B$13);(E32-D32-$B$11)) =F32+$B$12 =ПС($B$14;$B$15;-G32;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A33*B33 =C33*B33 =ЕСЛИ((E33-D33-$B$11)>0;(E33-D33-$B$11)*(1-$B$13);(E33-D33-$B$11)) =F33+$B$12 =ПС($B$14;$B$15;-G33;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A34*B34 =C34*B34 =ЕСЛИ((E34-D34-$B$11)>0;(E34-D34-$B$11)*(1-$B$13);(E34-D34-$B$11)) =F34+$B$12 =ПС($B$14;$B$15;-G34;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A35*B35 =C35*B35 =ЕСЛИ((E35-D35-$B$11)>0;(E35-D35-$B$11)*(1-$B$13);(E35-D35-$B$11)) =F35+$B$12 =ПС($B$14;$B$15;-G35;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A36*B36 =C36*B36 =ЕСЛИ((E36-D36-$B$11)>0;(E36-D36-$B$11)*(1-$B$13);(E36-D36-$B$11)) =F36+$B$12 =ПС($B$14;$B$15;-G36;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A37*B37 =C37*B37 =ЕСЛИ((E37-D37-$B$11)>0;(E37-D37-$B$11)*(1-$B$13);(E37-D37-$B$11)) =F37+$B$12 =ПС($B$14;$B$15;-G37;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A38*B38 =C38*B38 =ЕСЛИ((E38-D38-$B$11)>0;(E38-D38-$B$11)*(1-$B$13);(E38-D38-$B$11)) =F38+$B$12 =ПС($B$14;$B$15;-G38;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A39*B39 =C39*B39 =ЕСЛИ((E39-D39-$B$11)>0;(E39-D39-$B$11)*(1-$B$13);(E39-D39-$B$11)) =F39+$B$12 =ПС($B$14;$B$15;-G39;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A40*B40 =C40*B40 =ЕСЛИ((E40-D40-$B$11)>0;(E40-D40-$B$11)*(1-$B$13);(E40-D40-$B$11)) =F40+$B$12 =ПС($B$14;$B$15;-G40;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A41*B41 =C41*B41 =ЕСЛИ((E41-D41-$B$11)>0;(E41-D41-$B$11)*(1-$B$13);(E41-D41-$B$11)) =F41+$B$12 =ПС($B$14;$B$15;-G41;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A42*B42 =C42*B42 =ЕСЛИ((E42-D42-$B$11)>0;(E42-D42-$B$11)*(1-$B$13);(E42-D42-$B$11)) =F42+$B$12 =ПС($B$14;$B$15;-G42;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A43*B43 =C43*B43 =ЕСЛИ((E43-D43-$B$11)>0;(E43-D43-$B$11)*(1-$B$13);(E43-D43-$B$11)) =F43+$B$12 =ПС($B$14;$B$15;-G43;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A44*B44 =C44*B44 =ЕСЛИ((E44-D44-$B$11)>0;(E44-D44-$B$11)*(1-$B$13);(E44-D44-$B$11)) =F44+$B$12 =ПС($B$14;$B$15;-G44;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A45*B45 =C45*B45 =ЕСЛИ((E45-D45-$B$11)>0;(E45-D45-$B$11)*(1-$B$13);(E45-D45-$B$11)) =F45+$B$12 =ПС($B$14;$B$15;-G45;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A46*B46 =C46*B46 =ЕСЛИ((E46-D46-$B$11)>0;(E46-D46-$B$11)*(1-$B$13);(E46-D46-$B$11)) =F46+$B$12 =ПС($B$14;$B$15;-G46;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A47*B47 =C47*B47 =ЕСЛИ((E47-D47-$B$11)>0;(E47-D47-$B$11)*(1-$B$13);(E47-D47-$B$11)) =F47+$B$12 =ПС($B$14;$B$15;-G47;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A48*B48 =C48*B48 =ЕСЛИ((E48-D48-$B$11)>0;(E48-D48-$B$11)*(1-$B$13);(E48-D48-$B$11)) =F48+$B$12 =ПС($B$14;$B$15;-G48;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A49*B49 =C49*B49 =ЕСЛИ((E49-D49-$B$11)>0;(E49-D49-$B$11)*(1-$B$13);(E49-D49-$B$11)) =F49+$B$12 =ПС($B$14;$B$15;-G49;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A50*B50 =C50*B50 =ЕСЛИ((E50-D50-$B$11)>0;(E50-D50-$B$11)*(1-$B$13);(E50-D50-$B$11)) =F50+$B$12 =ПС($B$14;$B$15;-G50;0;0)-$B$16
=СЛУЧМЕЖДУ($B$7;$C$7) =СЛУЧМЕЖДУ($B$5;$C$5) =СЛУЧМЕЖДУ($B$6;$C$6) =A51*B51 =C51*B51 =ЕСЛИ((E51-D51-$B$11)>0;(E51-D51-$B$11)*(1-$B$13);(E51-D51-$B$11)) =F51+$B$12 =ПС($B$14;$B$15;-G51;0;0)-$B$16

Таблица 4 – Результаты анализа

Результаты анализа
Показатели Переменные Количество Цена Поступления NPV
Минимум 22 200 50 1611 3 202
Максимум 40 350 75 11804 45611
Среднее значение 31 275 62 6026 21570
Стандартное отклонение 5,64 43,24 7,42 2203,04 9165,56
Коэффициент вариации 18,2% 15,7% 12,0% 36,6% 42,5%
Число случаев NPV<0 0
Число случаев NPV>0 201
Сумма убытков 0
Сумма доходов 4335474,53
Вероятность p(NPV≤X)
X(NPV) Нормал. Х p(NPV≤X)
5500 -1,75 0,04

При сравнении доходов и убытков на примере данного проекта, можно принять решение по дальнейшему анализу для получения подтверждения данных расчетов и определения результативности.

В заключении можно сказать, что метод Монте-Карло имеет свои преимущества в использовании, такие как простота математики, легкость в использовании и легкость изменения. Он помогает убедиться в реальности проекта и имеет большую полезность для больших сложных проектов.


Библиографический список
  1. Гусева Е.Н. Имитационное моделирование экономических процессов в среде «Arena»: учеб. пособие: [электронный ресурс]. М.: Флинта, 2011. – 132 с. – Режим доступа: http://www.knigafund.ru/books/114189
  2. Гусева Е.Н. Математические основы информатики/ Е.Н. Гусева, И.И. Боброва, И.Ю. Ефимова, И.Н. Мовчан, С.А. Повитухин, Л.А. Савельева. –        Магнитогорск: Изд-во Магнитогорск. гос. техн. ун-та им. Г.И. Носова, 2016.- 234 с.
  3. Гусева Е.Н. Моделирование макроэкономических процессов: учеб. пособ.: [электронный ресурс]/ Е. Н. Гусева. – М.: Флинта, 2014.–214с.– Режим доступа: http://www.ozon.ru/context/detail/id/28975354/
  4. Гусева Е.Н., Варфоломеева Т.Н. Применение имитационных моделей для решения экономических задач оптимизации/Гусева Е.Н., Т.Н. Варфоломеева //Современные проблемы науки и образования. 2014. № 6. С. 200.
  5. Гусева Е.Н. Имитационное моделирование социально-экономических процессов. – Магнитогорск: изд-во Магнитогорск. гос. техн. ун-та им. Г.И. Носова, 2015. – 25с.
  6. Гусева Е.Н. Основы имитационного моделирования экономических процессов: лаб. практикум / Е.Н. Гусева. – Магнитогорск: МаГУ, 2008. – 100с.
  7. Гусева Е.Н. Методические рекомендации по дисциплине «программирование» для обучающихся направления 080500.62 «бизнес информатика» всех форм обучения/ Е. Н. Гусева, Т.Н. Варфоломеева. – Магнитогорск: изд-во Магнитогорск. гос. техн. ун-та им. Г.И. Носова, 2015. – 26с.
  8. Гусева Е.Н. Имитационное моделирование социально-экономических процессов. – Магнитогорск: изд-во Магнитогорск. гос. техн. ун-та им. Г.И. Носова, 2015. – 25с.
  9. Гусева Е. Н. Математика и информатика: [электронный ресурс]  учеб. пособие/ Е. Н. Гусева, И.Ю. Ефимова, И.Н. Мовчан,  Л.А. Савельева. – 3-е изд., стереотип. –М.: Флинта, 2015– 400 с. –Режим доступа:  lf5.com/Knigi/Nauka-Obrazovanie/Matematika/Matematika-i-informatika-148-103807
  10. Гусева Е. Н. Теория вероятностей и математическая статистика: учеб. пособие – 5-е изд., доп. и перераб.: [электронный ресурс]/ Е. Н. Гусева. –М.: Флинта, 2011.– 220 с. – Режим доступа: http://www.knigafund.ru/books/116083/read
  11. Курзаева Л.В. Дистанционный курс «Основы математической обработки информации»: электронный учебно-методический комплекс // Хроники объединенного фонда электронных ресурсов Наука и образование. – 2014.  -Т. 1. – № 12 (67). – С. 117
  12. Курзаева Л.В. Введение в теорию систем и системный анализ: учеб. пособие/Л.В. Курзаева. -Магнитогорск: МаГУ, 2015. -211 с
  13. Курзаева Л.В. Международный опыт управления качеством образования на основе рамочных структур/Л.В. Курзаева, И.Г. Овчинникова // «Научная дискуссия: вопросы социологии, политологии, философии, истории»: материалы VI международной заочной научно -практической конференции. Часть II (17 октября 2012 г.). -М.: Изд. «Международный центр науки и образования», 2012. -С. 51-56.
  14. Овчинникова И.Г., Курзаева Л.В. Математическое обеспечение информационной системы рейтинговой оценки учреждений высшего профессионального образования//Гуманитарные и социально -экономические науки. -2012. -№ 4. -С. 98-103.
  15. Курзаева Л.В. Дистанционный курс «Инструментальные методы поддержки принятия решений»: электронный учебно-методический комплекс//Хроники объединенного фонда электронных ресурсов Наука и образование. 2016. -№ 1 (80). -С. 2.


Все статьи автора «Прасолова Елизавета Александровна»


© Если вы обнаружили нарушение авторских или смежных прав, пожалуйста, незамедлительно сообщите нам об этом по электронной почте или через форму обратной связи.

Связь с автором (комментарии/рецензии к статье)

Оставить комментарий

Вы должны авторизоваться, чтобы оставить комментарий.

Если Вы еще не зарегистрированы на сайте, то Вам необходимо зарегистрироваться: